Multi Level Process Scheduling (revision 160216-r01)

Return to Lab 02

  1. Make sure X11 forwarding is enabled in the ssh configuration and you are using additional args -X in the ssh connection. For more information, please read man ssh.
  2. Download the files needed today:
    wget https://projects.ui.ac.id/attachments/download/8311/cpu.jar
    
  3. Download the simulation file:
    wget https://projects.ui.ac.id/attachments/download/8312/JobQueue.dat
    
  4. Run Simulation Program:
    java -jar cpu.jar
    

  5. Open File -> Open Data Source -> Choose File jobQueue.dat
  6. Open Option -> Choose Show hidden
  7. Choose Process Scheduling Algorithm by clicking Options -> Algorithm -> Choose appropriate Algorithm
  8. For Shortest Job First and Priority Algorithm you can select Preemptive or not by clicking Options -> Preemption
  9. Do the Simulation by clicking Check Box which is in the bottom mid of the simulation window.
  10. Your task is to do the simulation for these algorithms:
    1. Students with even-ending student ID do FCFS Algorithm while students with odd-ending student ID do Round Robin Algorithm.
    2. Students with the last student ID digit less than 5 (means 5 is NOT included) do simulation with Normal Priority, while students with the last student ID digit more than or equal to 5 (means 5 is included) do simulation with Preemptive Algorithm.
    3. Student with the last digit student ID 0,1,3,4,7 do simulation with Normal Shortest Job First while student with the last digit 2,5,6,8,9 do simulation with Preemptive Shortest Job First.
  11. Each student will do three simulations above and write the result on WHAT-IS-THIS.txt file.
  12. In the end of each simulation, add your explanation about the algorithm that you used in the text file.
  13. This is the end of Multi Level Process Scheduling Task.

Return to Lab 02
Return to Wiki